Firefox crashing on your Site....

I have a big problem, my main browser is Firefox.
I used Firefox to access this site,
but since a few days it keeps crashing
when clicking on links to new threads (giveaways posts etc.).
I waited for like 2 minutes once, but then just closed it,
since it wasn't responding at all ^^

thank you for any possible help :)

Comments

  • nuraxcs said:

    I have a big problem, my main browser is Firefox.
    I used Firefox to access this site,
    but since a few days it keeps crashing
    when clicking on links to new threads (giveaways posts etc.).
    I waited for like 2 minutes once, but then just closed it,
    since it wasn't responding at all ^^

    thank you for any possible help :)

    thats very odd, Im also using firefox, and Ive yet to get crashed on our site

    can you try and see if it does the same thing with other browser? would need to know so that i can eventually forward this to Carl
  • No problem here with Firefox.. Make a scan with Malware Bytes and also check for malicious browser extensions.
  • Tatsuya said:

    nuraxcs said:

    I have a big problem, my main browser is Firefox.
    I used Firefox to access this site,
    but since a few days it keeps crashing
    when clicking on links to new threads (giveaways posts etc.).
    I waited for like 2 minutes once, but then just closed it,
    since it wasn't responding at all ^^

    thank you for any possible help :)

    thats very odd, Im also using firefox, and Ive yet to get crashed on our site

    can you try and see if it does the same thing with other browser? would need to know so that i can eventually forward this to Carl
    Everything working fine in Chrome. :)
    Kouman said:

    No problem here with Firefox.. Make a scan with Malware Bytes and also check for malicious browser extensions.

    Yeah, same here a couple days ago. Just started...
    I haven't installed (ᵔᴥᵔ) during that time,
    keeping my PC clean... :o
  • I scanned PC with ADWCleaner and Malware Bytes.
    Not a single detection... Disabled all plugins for the test. :)
  • I think the Twitch widget cause the problem.
  • I recently fixed an issue with Firefox. Hopefully it runs a lot better now.
  • I does. Gonna reactivate my Plugins...
    Let's see if it keeps running that great :)

    Thank you, Carl.
  • //everything fixed. don't know how though :D
This discussion has been closed.